Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Cannot activate LSAC account through 7Sage.

nate12111111nate12111111 Alum Member

Hello everyone,

I just bought my 7sage account today along with the necessary LSAC subscription. When I try to look at the Prep tests, it says I need to activate my account with LSAC. However, by clicking it it just brings me to their login page and when I try to create an account, it says my email as already been used, despite the fact that when I click the forgot password and username function, they cannot find any record for that email. Alternatively, the email LSAC has sent me as a "get started" function which does the exact same thing. All in all, I am unable to look at the Preptests at all sometimes. Has anyone else had this problem before and if so, how was it solved? Also I would appreciate it if technical support could answer this question.

Thanks

Comments

  • Juliet - Student ServiceJuliet - Student Service Member Administrator Student Services
    5740 karma

    @nathanye123456 said:
    Hello everyone,

    I just bought my 7sage account today along with the necessary LSAC subscription. When I try to look at the Prep tests, it says I need to activate my account with LSAC. However, by clicking it it just brings me to their login page and when I try to create an account, it says my email as already been used, despite the fact that when I click the forgot password and username function, they cannot find any record for that email. Alternatively, the email LSAC has sent me as a "get started" function which does the exact same thing. All in all, I am unable to look at the Preptests at all sometimes. Has anyone else had this problem before and if so, how was it solved? Also I would appreciate it if technical support could answer this question.

    Thanks

    Hi there,

    Sorry for the trouble! LSAC is aware of login issues on their site, and recommend that you please try the following:

    Click on the link on 7Sage's site or through the email from LSAC to link your LSAC Prep Plus account to your 7Sage account.

    LSAC also recommends that you try the following:

    1. Turn off “Prevent Cross-site traffic.” How to turn it off: https://lsac.zendesk.com/hc/en-us/articles/360046003674-Why-am-I-having-issues-with-Safari-on-Mac-iOS-or-iPadOS
    2. Use another browser such as Chrome. Get Chrome for Mac (https://www.google.com/chrome/) or iOS (https://apps.apple.com/ca/app/google-chrome/id535886823)
    3. If on Mac, update your OS to at least MacOS 10.15.4. How to check: https://support.apple.com/en-ca/HT201260

    Let us know if this helps!

  • c_o_r_b_i_nc_o_r_b_i_n Member
    7 karma

    I am having a similar issue. I am able to see and take PrepTests through LSAC, but, when I go to the PrepTests section on 7Sage, it says that I need to activate my account. I click the button, and it takes me to the LawHub page and logs me in and everything, but nothing happens on 7Sage. I tried the recommendations above and they didn't work. I am using Firefox on Windows. Thank you in advance for your help!

  • nate12111111nate12111111 Alum Member
    41 karma

    Sorry for the trouble! LSAC is aware of login issues on their site, and recommend that you please try the following:

    Click on the link on 7Sage's site or through the email from LSAC to link your LSAC Prep Plus account to your 7Sage account.

    LSAC also recommends that you try the following:

    1. Turn off “Prevent Cross-site traffic.” How to turn it off: https://lsac.zendesk.com/hc/en-us/articles/360046003674-Why-am-I-having-issues-with-Safari-on-Mac-iOS-or-iPadOS
    2. Use another browser such as Chrome. Get Chrome for Mac (https://www.google.com/chrome/) or iOS (https://apps.apple.com/ca/app/google-chrome/id535886823)
    3. If on Mac, update your OS to at least MacOS 10.15.4. How to check: https://support.apple.com/en-ca/HT201260

    Let us know if this helps!

    Hello, thank you for the response, but I've tried all of those things already and it is still not working. When I click on the link in the 7sage site and in their email, I just get brought to the login pace.

  • musumecibjjmusumecibjj Alum Member
    94 karma

    I had the same problem! try using a different browser such as firefox. That's what worked for me!

  • Theo - Student ServiceTheo - Student Service Member Moderator Student Services
    845 karma

    @c_o_r_b_i_n @nathanye123456

    If changing web browsers didn't seem to work, you can also try to link your LSAC Prep Plus account to your 7Sage account using a different device then go through the steps.

    Please let me know how it goes. You can also send us an email at studentservice@7sage.com

  • quagmirequagmire Alum Member
    96 karma

    @"Theo --Student Service--"
    I'm having the exact same problem as Nathan. I didn't have an LSAC account prior to purchasing 7sage. I'm using chrome and have had problems on both my laptop and ipad.

Sign In or Register to comment.